Showing posts with label enterprise. Show all posts
Showing posts with label enterprise. Show all posts

Wednesday, May 17, 2017

OSGi Community Event 2017 CFP


is licensed under CC BY_SA 2.0.
The OSGi Community Event Program Committee is pleased to announce that the Call For Papers (CFP) for the 2017 event is NOW OPEN.

We are looking for submissions from anyone who has something to share about OSGi technology, the OSGi ecosystem or OSGi community.  All successful submissions receive a free speaker all access pass to the OSGi Community Event and EclipseCon Europe.

Popular topics often include use cases and case studies of using OSGi, OSGi open source projects or commercial OSGi products where you have some experience to share. Presentations on tools and frameworks that can improve the developer experience are also well received.  We are also looking for a 3-hour tutorial, so if you have a project or some examples on an OSGi specification where the audience can participate with you then we would welcome your submissions.



OSGi is used in many different environments and markets and we are interested in hearing from your use in any of them, be it enterprise, telecommunications, transport, retail, IoT, Industry 4.0, M2M, Cloud, or Smart Home, to name just a few.

It's always great to get submissions from new members to the community and/or new speakers so please don't be shy and get your submissions in.  Whether what you have to share is small or large, state-of-the-art or traditional, business critical or a pet project, we want to hear from you.

Your submission should be either for a 35-minute talk or a 3-hour tutorial. 

We are sharing the submission system with EclipseCon Europe so please be sure to select OSGi as the track when making your submission to be sure the OSGi Program Committee will get to review your proposal.

The CFP is open until July 17, however the Early Bird submission deadline is June 30.

As an added incentive to get your submissions in for the Early Bird deadline we will award a €50 Amazon Voucher to the talk selected for the OSGi Early Bird pick. Be sure to submit by June 30 to be in with a chance of winning this.


The OSGi Community Event 2017 will be taking place between October 24 to 26.  Once again this year the event is being held at the Forum am Schlosspark in Ludwigsburg, Germany.  As always there will be plenty of talks, BOFs, social events, beer, wine and food so make sure you have the dates in diary and start planning your travel and accommodation early.

If you have any questions please contact us by email.

Thursday, March 16, 2017

New OSGi R7 spec drafts published

In the OSGi Enterprise and Core Platform Expert Groups we are working hard on the upcoming R7 specifications, which are planned to be released later this year. Recently the OSGi Alliance published the current drafts of some these specs.

In this blog post you can read a very brief summary of what is new, for all the further details look in the drafts.
In the Enterprise draft specification - new and changed are:

  • Remote services (ch 100) - has been enhanced to include new standard intents that require minimum remote service capabilities, asynchronous processing or a private remote connection.
  • Declarative Services (ch 112) - this spec has received a substantial update, including delayed object reclamation, component property type enhancements and other updates.
  • JPA Service (ch 127) - has been updated to support JPA 2.1, supports standard JPA 2.1 configuration properties with the EntityManagerFactoryBuilder and now specifies a number of standard Capabilities to integrate better with the Resolver.
  • new Transaction Control Service (ch 147) - this new specification provides an improved mechanism to perform work in a transaction scope. It provides a higher level of abstraction than the existing JTA integration specification, and makes it really easy to write transactional code, especially when using Java 8 lambdas.
  • new Configurator Specification (ch 150) - the configurator makes it possible to store configuration data for Configuration Admin driven entities in a bundle. The configuration is stored in a spec-defined format inside the bundle and can be used to configure any number of bundles, components, services or other entities via the Configuration Admin Service.
  • Promises specification (ch 705) - this spec is now updated with a number of improvements including timeouts, easier exception handling and callbacks.
  • new Push Streams (ch 706) -  This new spec provides a programming model similar to Java 8 pull-based streams, but then using a push model. This can be very useful for data such as events that arrives asynchronously. The data can be mapped, buffered, splitted, filtered or otherwise processed before it gets pushed to the receiver. 
  • new Converter (ch 707) - This spec defines a portable converter that can convert nearly everything to nearly anything. Especially useful then converting untyped data such as a Map to a typed API such as an interface, DTO or annotation. Converters can also be customized to support user-defined types or to create deviations from standard behavior.
The Core Specification has also been updated. Besides a number of small changes and improvements - see the Changes sections in each chapter for details - the Core spec now defines new Annotations in the org.osgi.annotation.bundle package that can be used to define bundle headers from inside the Java code of your bundle. For example, these can be used to declare requirements and capabilities that your bundle could have or to declare which packages should be exported.

The R7 March 2017 drafts for the Core and Enterprise specs can now be downloaded from here: https://www.osgi.org/developer/specifications/drafts

Finally, not yet in the draft, but coming up as well are:

  • Cluster Information Specification (previously known as Cloud Ecosystems), from RFC 183.
  • CDI integration, you can read more about this in RFC 193.
  • JAXRS integration, see RFC 217.
  • HTTP Whiteboard Extensions, RFC 223.
  • Resolver Service updates: RFC 224.
  • Configuration Admin updates, RFC 227.

Thursday, March 9, 2017

OSGi at CeBIT 2017


The OSGi Alliance is pleased to be returning to CeBIT again this year between Monday March 20 to Friday March 24.

We will be showcasing the popular OSGi IoT Demo which uses a number of different OSGi open source projects, and commercial products from OSGi Alliance members (Bosch, Eclipse, Eurotech, imec, Makewave, Paremus and Skelmir) to manage and control the operation of LEGO® trains. This really is a great example of the interoperability of the OSGi specifications and demonstration of how an IoT ecosystem can be created using OSGi technology.

You can find us on Stand C62 in the IoT / M2M Pavilion located in Hall 12 [Map].

Be sure to stop by and say hello . You will also be able to find out more about what we are doing in the demo and broader OSGi activities. You can also take the opportunity to interact with the sensors and RFID tags in the demo to see the affect they have on the LEGO® trains running around the track.

A number of the OSGi IoT and Enterprise Expert Group members will be on hand to answer any questions you may have about OSGi and its use in IoT and also Enterprise and Cloud.  We would also be pleased to discuss with you about how you can get involved and contribute to new specifications and also join the OSGi Alliance.

IoT Expert Conference Keynote Presentation


Kai Hackbarth, from Bosch, an OSGi Alliance Board Member, will be making a keynote presentation on behalf of the OSGi Alliance on Thursday March 23 at 1.40pm.

 'How OSGi can help to build open IoT ecosystems ?"
IoT is already revolutionising our lives at home, in the car, at work and many other places. With predictions of 20+ billion devices and beyond the IoT impact has only just begun. To support this phenomenal growth and change whats needed is an open modular and service based platform that can support an evolving and dynamic ecosystem. We will look at how OSGi specifications make this a reality, and explore use cases that prove its deliverable today. Further details are available online.

Complimentary Tickets to CeBIT


If you would like to attend CeBIT, and (of course) come and see us or watch the OSGi Keynote we have some complimentary tickets available.  Please contact the OSGi marketing team to request your ticket.

Hope to see you in Hanover March 20 to 24.

Tuesday, February 28, 2017

OSGi API Snapshots are Live!

Sometime back, OSGi began to make all design document (RFC) drafts available in real time from the OSGi Design GitHub repository. In furtherance of providing real time access to the latest design work at OSGi, OSGi made a change to the OSGi build process. Previously, the various OSGi specification's API code had only been published by the Alliance once a specification release has been declared final. Since mid February, however, the OSGi build has been publishing API snapshots to the public https://oss.sonatype.org/content/repositories/osgi/ group repository! Many thanks to BJ Hargrave for making this happen.

So why should you care?

Broadly speaking, the people who care about the pre-release OSGi APIs fall into two sets:
  1. The people who want to try out the new draft APIs in their applications.
  2. The people who want to implement the new draft APIs.
At first glance, it looks like the new release policy only helps the second group - after all it saves them from some issues
  • How do I keep up to date with the OSGi RFCs?
  • Is there a way to avoid duplicating the OSGi draft API source code?
But actually there are two important ways that publishing snapshots directly helps users:
  1. By making it easier for implementors to keep up to date with RFCs, users get faster access to new implementations of the draft API.
  2. For implementation code published by the OSGi Alliance, you get access to the draft code right now!
A good example of this would be OSGi Push Streams. You may have already watched the talk I gave in Portland about them, and been wondering when you could try them out. The answer is right now, and the same is true for the new 1.1 version of OSGi Promises!

Helping implementors

Open Source implementations of OSGi specifications are already moving to use the new draft API snapshots from OSGi (for example the Aries JAX-RS whiteboard). In most cases the API can be simply referenced from the OSGi group repository and no further action is needed.

One thing worthy of note is that the latest OSGi APIs are all compiled using Java 8. For some implementations, this is a problem as they wish to include the API inside their bundle but also to be usable on older versions of Java. In these cases, implementors may wish to try using a tool such as the Retrolambda project, so that they can still benefit from the published snapshots.

We hope that you enjoy the chance to play with all the cool new specifications!

Thursday, October 20, 2016

OSGi R7 early spec drafts available

Recently OSGi published the first early draft for the OSGi R7. While not all specs aimed for R7 are present yet, a few new ones have appeared that can be checked out. The new ones are:
  • Chapter 147 - Transaction Control Service. This specification provides an improved mechanism to perform work in a transaction scope. It provides a higher level of abstraction than the extising JTA integration specification, which makes it really easy to write transactional code, especially when using Java 8 lambdas.
  • Chapter 148 - Converter. Convert anything into everything, and back. A universal object converter which can be used to convert simple values between datatypes, but it can also be used to convert complex structures such as maps or DTOs to interfaces or annotations. Previously functionality such as this was already supported in DS, which allows you to access a component's configuration map via an annotation. Now, this can be used anywhere you like...
  • Chapter 706 - Push Streams. These provide a programming model similar to Java 8 pull-based streams, but then using a push model. Useful for data such as events that arrives asynchronously. The data can be mapped, buffered, splitted, filtered or otherwise processed before it gets sent to the receiver. 
You can find the R7 early drafts at the OSGi website here: https://www.osgi.org/developer/specifications/drafts/
Opensource implementations are already starting to appear, check https://en.wikipedia.org/wiki/OSGi_Specification_Implementations for where to obtain OSGi specification implementations.

As always, these are early drafts. Things will definitely change in some of the details. If you want to learn more about these and other upcoming OSGi specifications, come and visit the OSGi Community Event at EclipseCon Europe in Ludwigsburg https://www.osgi.org/2016-osgi-community-event.